reCAPTCHA code

Ask Chronicle Theme Installation, Settings & Configuration, Problem, Error & Bug Related Issues Here

Moderator: forum_m

Post Reply
salyubenova
Posts: 25
Joined: November 3rd, 2016, 12:18 am

reCAPTCHA code

Post by salyubenova » June 9th, 2018, 11:10 pm

Hello, I need to put the reCaptcha code in the contact form as directed by Google, but do not know where? I use child theme. Would you please tell me where to add?
1. Client site integration
Paste this snippet before the closing </head> tag on your HTML template:
<script src='https://www.google.com/recaptcha/api.js'></script>
2. Paste this snippet at the end of the <form> where you want the reCAPTCHA widget to appear:
<div class="g-recaptcha" data-sitekey=".............."></div>
Thank you!

support_staff
Posts: 7164
Joined: February 26th, 2015, 1:40 pm

Re: reCAPTCHA code

Post by support_staff » June 11th, 2018, 10:55 am

Hello,

Please follow the below steps -

Step 1: First You login to https://www.google.com/recaptcha/ and generate your website Unique reCAPTCHA code.

Step 2: Go to your wordpress admin panel. Open up Edit templates. Find and edit the header file. Paste this snippet before the closing </head> tag on your HTML template.
<script src='https://www.google.com/recaptcha/api.js'></script> and save.

Step 3: Open up and edit your contact-us.php file. Paste this snippet at the end of the <form> where you want the reCAPTCHA widget to appear.

<div class="g-recaptcha" data-sitekey="your_data_key_that_you_generated_in_google"></div>

Thats it, now the Google reCAPTCHA shows up on your contact form.

Hope it helpful for you!

salyubenova
Posts: 25
Joined: November 3rd, 2016, 12:18 am

Re: reCAPTCHA code

Post by salyubenova » June 12th, 2018, 12:52 am

Thank you! It's done!

support_staff
Posts: 7164
Joined: February 26th, 2015, 1:40 pm

Re: reCAPTCHA code

Post by support_staff » June 12th, 2018, 10:22 am

Your Welcome,

Let us know for further query.

Post Reply

Return to “Theme Installation, Settings & Configuration, Problem, Error & Bug”