Enigma Services and Menu Icons Not Working

Ask Enigma Premium Theme Installation, Settings & Configuration, Problem, Error & Bug Related Issues Here

Moderator: forum_m

Post Reply
mscmedia
Posts: 4
Joined: January 30th, 2017, 12:28 pm

Enigma Services and Menu Icons Not Working

Post by mscmedia » August 8th, 2019, 1:38 pm

Hi there,
Could you please help with an issue we are having with our site. The icons for our services, as well as in our dropdown menus are no longer working. They are showing a rectangle and letters instead. I have checked that the font awesome codes are correct and current, but they still don't appear on the site.
The site is:
http://www.wheatbelttourism.com/

support_staff
Posts: 7188
Joined: February 26th, 2015, 1:40 pm

Re: Enigma Services and Menu Icons Not Working

Post by support_staff » August 9th, 2019, 12:06 pm

Hi,

For the service icon, use the below CSS code in custom CSS editor box and save the changes.

Code: Select all

.enigma_service_iocn i {
    font-family: "Font Awesome 5 Free";
    font-weight: bold;
}.dropdown-menu > li > a:before {
    font-family: "Font Awesome 5 Free";
    font-weight: bold;
}
Which type of menu do you want? Please let me know clearly.

Thanks & let me know if you need help.

mscmedia
Posts: 4
Joined: January 30th, 2017, 12:28 pm

Re: Enigma Services and Menu Icons Not Working

Post by mscmedia » August 9th, 2019, 6:22 pm

Hello support_staff,
Thank you kindly for sending through the code. I have added the code to the custom CSS editor and it has restored the service icons as well as the arrow icons in the top header menu.

I have also noticed that there is a menu in the footer panel that is showing the same issue. Is there some additional code I can add to restore these icons as well?

Thanks so much for your help, I appreciate it.

mscmedia
Posts: 4
Joined: January 30th, 2017, 12:28 pm

Re: Enigma Services and Menu Icons Not Working

Post by mscmedia » August 9th, 2019, 6:35 pm

In addition to the above (where we lost the icons from the footer menu), we have also lost the icons on some right side bar menus. Hopefully there is some magical code we can enter to restore those as well :)

Sorry, I also forgot to ask about a separate issue we are having with the search bar.
We provide information about local events on our website, but the search bar won't return any results if the event name is searched.

For example, if we type in "wildflowers" into the search bar, then it will show page results relating to wildflowers in our website. But if we type in "Tammin Markets" it returns a 404 error page, even though we have an event called Tammin Markets. The events plugin we are currently using is not created by you, so we are not sure if it is a compatibility issue with the theme. Do you think we should be using a different calendar and events plugin?

Thanks so much for your help

support_staff
Posts: 7188
Joined: February 26th, 2015, 1:40 pm

Re: Enigma Services and Menu Icons Not Working

Post by support_staff » August 10th, 2019, 10:49 am

Hi,

1) For right sidebar -

Code: Select all

.enigma_sidebar_widget ul li a:before, .enigma_footer_widget_column ul li a:before {
    font-family: "Font Awesome 5 Free";
    font-weight: bold;
}
.enigma_sidebar_widget ul li a:before, .enigma_footer_widget_column ul li a:before {
    font-family: "Font Awesome 5 Free";
}
2) When I search about the event, it searches the event list and it is right.

https://i.postimg.cc/k4z865DN/event.png

Search form only searches the page/post content, not the particular topics content.

Hope you understood.


Thanks & let me know if need help.

mscmedia
Posts: 4
Joined: January 30th, 2017, 12:28 pm

Re: Enigma Services and Menu Icons Not Working

Post by mscmedia » August 11th, 2019, 10:39 am

Thank you very much for providing the code, the issues have all been solved.

support_staff
Posts: 7188
Joined: February 26th, 2015, 1:40 pm

Re: Enigma Services and Menu Icons Not Working

Post by support_staff » August 14th, 2019, 10:45 am

you're welcome :)

Post Reply

Return to “Theme Installation, Settings & Configuration, Problem, Error & Bug”