php 7.3 compatibility?

Ask Enigma Premium Theme Installation, Settings & Configuration, Problem, Error & Bug Related Issues Here

Moderator: forum_m

Post Reply
ben1woelk
Posts: 6
Joined: October 27th, 2017, 7:50 pm

php 7.3 compatibility?

Post by ben1woelk » June 24th, 2020, 9:24 pm

I'm running Enigma Premium Advance 3.6
I need to update from PHP 7.0. However, running PHP Compatibility Checker before updating to 7.3, I get the errors below. I'm going to update to 7.1 for now, but would like to know the status of the theme being compatible with 7.3

Errors:
FILE: /home/theint16/public_html/wp-content/themes/enigma-premium-advance/core/admin/WL_Weblizar_LC.php
-------------------------------------------------------------------------------------------------------------------------------------------------------
FOUND 11 ERRORS AFFECTING 5 LINES
-------------------------------------------------------------------------------------------------------------------------------------------------------
524 | ERROR | Function mcrypt_module_open() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
524 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
524 | ERROR | The constant "MCRYPT_BLOWFISH" is deprecated since PHP 7.1 and removed since PHP 7.2
525 | ERROR | Function mcrypt_create_iv() is deprecated since PHP 7.1 and removed since PHP 7.2; Use random_bytes() or OpenSSL instead
525 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
525 | ERROR | The constant "MCRYPT_RAND" is deprecated since PHP 7.1 and removed since PHP 7.2
585 | ERROR | Function mcrypt_generic() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
585 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
605 | ERROR | Function mdecrypt_generic() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
631 | ERROR | Function mcrypt_generic_init() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
631 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
-------------------------------------------------------------------------------------------------------------------------------------------------------

support_staff
Posts: 7277
Joined: February 26th, 2015, 1:40 pm

Re: php 7.3 compatibility?

Post by support_staff » June 25th, 2020, 12:00 pm

You can use 7.3 or 7.4 theme compatible with it

ben1woelk
Posts: 6
Joined: October 27th, 2017, 7:50 pm

Re: php 7.3 compatibility?

Post by ben1woelk » June 25th, 2020, 7:57 pm

So I can safely ignore the issues that PHP checker identified?
Thanks!

support_staff
Posts: 7277
Joined: February 26th, 2015, 1:40 pm

Re: php 7.3 compatibility?

Post by support_staff » June 26th, 2020, 10:37 am

Yes you can

Post Reply

Return to “Theme Installation, Settings & Configuration, Problem, Error & Bug”